DFRobotShop Mecanum Rover 2.0 - Arduino Compatibele Robot (Basis Kit)

RobotShopArtikelnummer:RB-Rbo-96
Fabrikant #: RB-Rbo-96

Prijs  :
Verkoopprijs €199,25

Inclusief belasting

Verzending berekend bij het afrekenen

Voorraad  :

Binnenkort nieuwe voorraad Zie vervaldatum

Laat me weten wanneer dit product op voorraad is

Betalingen en veiligheid

Betaalmethodes

Apple Pay Mastercard PayPal Visa

Uw betalingsgegevens worden veilig verwerkt. We slaan geen creditcardgegevens op en hebben ook geen toegang tot uw creditcardgegevens.


Veiligheid

Description

  • Programmeerbaar door Mecanum aangedreven robotkit
  • Volledig ingebouwd Arduino-bord (ATMega328p)
  • Twee dubbele H-bruggen voor onafhankelijke aansturing van vier motoren
  • Spanningsregelaar aan boord (slechts één batterij nodig)
  • Compatibel met verschillende soorten schilden
  • Solderen is vereist
  • LiPo-batterij wordt apart verkocht


De DFRobotShop Mecanum Rover 2.0 - Arduino Compatibele Robot is een veelzijdige mobiele robot gebaseerd op de populaire Arduino Uno microcontroller. De Rover gebruikt twee Tamiya Twin-Motor Versnellingsbak , elk met hun eigen paar encoders, evenals een schild met dubbele motorbesturing ** om de vier Mecanum-wielen onafhankelijk te besturen. De DFRobotShop Rover PCB bevat een standaard Arduino Uno (Surface Mount ATMega328), L293B-motorstuurprogramma (aangesloten op pennen 5 tot 8), spanningsregelaar en prototyperingsgebied en verdubbelt ook als onderdeel van de mechanische structuur van de robot. Met de ingebouwde spanningsregelaar kan het hele bord worden gevoed met zo weinig als 3.7V tot ~ 9V *.

 

DFRobotShop Mecanum Rover 2.0 - Arduino Compatible Robot (Basic Kit)

De DFRobotShop Rover 2.0 Arduino-compatibele robot bouwt voort op het succes van de eerste generatie DFRobotShop Rover V2 - Arduino Compatibele Robottank (Basisset) en integreert een LiPo-oplader (opladen via USB), soldeer prototypegebied, XBee-voetafdruk en meer. Met Mecanum omni-directionele wielen kan de Rover in de volgende richtingen bewegen:

DFRobotShop Mecanum Rover 2.0 - Arduino Compatible Robot (Basic Kit)


Het is belangrijk op te merken dat als gevolg van de betrokken krachten sommige richtingen merkbaar langzamer zijn dan andere. Als een voorbeeld, vooruit en achteruit is aanzienlijk sneller dan direct links en rechts. Het draaien van CW / CCW over het middelpunt duurt langer dan bij een 2WD rover.

* Motoren die bij de Tamiya-versnellingsbak worden geleverd, werken op maximaal 5V. 6V-motoren zijn afzonderlijk verkrijgbaar.
** De DFRobotShop Rover PCB heeft een tweevoudige motorbesturing en het schild voegt een dubbele controller toe die verschillende pins gebruikt, waardoor u vier DC-motoren onafhankelijk van elkaar kunt besturen.


LiPo-batterij wordt apart verkocht

Customer Reviews

Based on 3 reviews
0%
(0)
0%
(0)
67%
(2)
33%
(1)
0%
(0)
S
Shivan
Varying Quality on parts and some issues documentation.

I would start off by saying this is a review for the overall kit and that the controller board is excellent albeit with one issue I've found so far which I can identify as a defect with the one I received or maybe something that got past QA in general. Firstly, the highlights of the kit, the board controller board is exceptional and the expansion board provides more or less everything you need to at least get this up and moving quickly. The wheels are good quality so no issues there. The downsides, firstly the encoder discs shipped with the kit are plastic and the hex shaped hole for two I received was smaller than the shaft so slotting them in caused them to break easily, I quickly switched to cardboard cut outs for the wheels that I could not salvage. The next major issue is with the powering, the supplied resources suggests a 3.7V LiPo battery with at least 1000 mAh so I got one. I didn't see any issues while I was debugging and testing using the serial/usb interface with the LIPO connected and all 4 motors would spin properly. Then when I disconnected the USB the motors would spin for less than 1 second and then it would look like the board just stopped working, I began to worry I shorted something in the board but as soon as I plugged it back into the computer via the USB it was working normally again. That point on it was testing different configurations to figure out what was going wrong, which included powering multiple motors in different combinations to see if one was shorted and maybe just drawing too much power but that didn't result in any issues either. The issue only came up when I tried running all 4 motors at the same time. I thought it was a current draw issue (I didn't do the maths but it shouldn't have been) and maybe I was not supplying enough power to the system so I switched out the LiPo to 4xAA batteries and the battery pack so I removed the L1_SEL jumper while I was debugging and everything seemed to work while connected and not connected via USB. Just to cover all my bases I tried the LiPo again but with L1_SEL jumper not connected and now it seemed to work both connected and disconnected with the USB which was a bit confusing. Turns out that having the L1_SEL jumper connected and running all the motors led to some issues and I cannot figure out why. It's not a big issue since when I'm using it now I just pull out that jumper and the system works without issue but I cannot find this behaviour documented anywhere so I just wanted to make anyone aware of that.

S
Shivan
Qualité variable sur les pièces et certains problèmes de documentation.

Je commencerais par dire qu'il s'agit d'un examen du kit global et que la carte contrôleur est excellente, mais avec un problème que j'ai trouvé jusqu'à présent que je peux identifier comme un défaut avec celui que j'ai reçu ou peut-être quelque chose qui a dépassé le contrôle qualité. en général. Tout d'abord, les points forts du kit, la carte contrôleur de la carte est exceptionnelle et la carte d'extension fournit plus ou moins tout ce dont vous avez besoin pour au moins le faire fonctionner rapidement. Les roues sont de bonne qualité donc pas de problèmes. Les inconvénients, tout d'abord, les disques encodeurs livrés avec le kit sont en plastique et le trou en forme hexagonale pour deux que j'ai reçu était plus petit que l'arbre, donc les insérer les a fait se casser facilement, je suis rapidement passé à des découpes en carton pour les roues que je pouvais pas de sauvetage. Le prochain problème majeur concerne l'alimentation, les ressources fournies suggèrent une batterie LiPo de 3,7 V avec au moins 1000 mAh, donc j'en ai eu une. Je n'ai vu aucun problème pendant le débogage et les tests en utilisant l'interface série / USB avec le LIPO connecté et les 4 moteurs tournaient correctement. Ensuite, lorsque j'ai déconnecté l'USB, les moteurs tournaient pendant moins d'une seconde, puis il semblerait que la carte ait cessé de fonctionner, j'ai commencé à m'inquiéter, j'ai court-circuité quelque chose dans la carte, mais dès que je l'ai rebranché à l'ordinateur via le USB, il fonctionnait à nouveau normalement. Ce point à ce sujet consistait à tester différentes configurations pour déterminer ce qui n'allait pas, ce qui comprenait l'alimentation de plusieurs moteurs dans différentes combinaisons pour voir si l'un était en court-circuit et peut-être simplement trop de puissance, mais cela n'a pas non plus posé de problèmes. Le problème ne s'est posé que lorsque j'ai essayé de faire fonctionner les 4 moteurs en même temps. Je pensais que c'était un problème de tirage au sort (je n'ai pas fait le calcul mais cela n'aurait pas dû l'être) et peut-être que je ne fournissais pas assez d'énergie au système, alors j'ai changé le LiPo en 4xAA et le pack de batterie, donc je retiré le cavalier L1_SEL pendant le débogage et tout semblait fonctionner lorsqu'il était connecté et non connecté via USB. Juste pour couvrir toutes mes bases, j'ai à nouveau essayé le LiPo mais avec le cavalier L1_SEL non connecté et maintenant il semblait fonctionner à la fois connecté et déconnecté avec l'USB, ce qui était un peu déroutant. Il s'avère que le fait d'avoir le cavalier L1_SEL connecté et de faire fonctionner tous les moteurs a conduit à des problèmes et je ne peux pas comprendre pourquoi. Ce n'est pas un gros problème puisque lorsque je l'utilise maintenant, je viens de retirer ce cavalier et le système fonctionne sans problème, mais je ne trouve pas ce comportement documenté nulle part, donc je voulais juste en informer quiconque.

J
Joel
Let down by one flaw

Kit is of reasonable physical quality, except the USB port is only soldered down and quite weak. Major design flaw in the board is that the PWM output for the motors uses up all the timer pins on the arduino. ------------------------------------------------------------------------------------------------------------- Hi Joel, We are certainly sorry to hear that you had an issue with the USB connector, and assuming the product was under warranty, would have replaced the entire board free of charge. With regard to the pinout, we had to choose four pins to dedicate to the onboard dual motor controller. We did our bes tot choose pins which are as little used by other shields as possible. Unfortunately a Mecanum driven robot requires a total of four H-bridges (each needs one digital pin and one PWM pin), meaning a total of eight of the 13 digital pins on the Arduino are used. If you add encoders, those require a further four pins, leaving only the analog and either the Tx or Rx pin. The RobotShop Team

Verzending schatten:

Dit vind je misschien ook leuk